Vultr.com - Instant Cloud Server Deployment
Game Rank
Servers:
Teams:
Fans:
1527
Players:
1
general_nagaPM
#1
Custom Mods
Jan 25, 2011 9:42 AM
Joined: Oct 13, 2008
Posts: 9
I've spent the last few hours trying to run a custom mod on the server but I can't seem to edit the startup command successfully.

I've got a dedicated server setup on one of my own machines and the mod works perfectly on that so I assume this is an server admin issue.

Curiously I installed MWLL as a test and that is now loaded by default everytime. How is that being loaded? There's nothing in the startup command box.

Thanks for anyone who can help

- Realism - Tactics - Teamwork -
general_nagaPM
#2
Jan 25, 2011 6:35 PM
Joined: Oct 13, 2008
Posts: 9
After many hours of testing I've discovered that the server "freezes" after editing the Startup Command Line.

After editing it I can no longer restart the server and the server stops working for clients and is shown as "dead" by the gametracker profile. However in the admin panel it shows as being online and working. Furthermore the logs show the last log before the command line was changed.

I've found the current log in the warhead root folder but its incomplete and the game stops loading before GameSpy initiates.

The mod works fine on other dedicated servers and I've tried it with just a single map in the mod (no code changes) - so I can only assume the problem is related to edit command line.

Any suggestions?

- Realism - Tactics - Teamwork -
exeterhxPM
#3
Jul 18, 2011 6:36 PM
Joined: Feb 11, 2011
Posts: 1
rolf
te5laPM
#4
Mar 16, 2014 1:25 AM
Joined: Jul 25, 2010
Posts: 33
Mods are launched by creating a shortcut of the dedicated server EXE and modifying the properties so the target is appended with:

-mod NameOfMod

The "NameOfMod" being what the mod's actual folder under Mods\ is named.
Join [xTc] Forums: http://xtc.getmyip.com