Vultr.com - Instant Cloud Server Deployment
Game Rank
Servers:
Teams:
Fans:
26237
Players:
337
Forum Home > Battlefield Bad Company 2 General Discussion > playing on two computers in same house online.
johanwepenerPM
#1
playing on two computers in same house online.
Oct 14, 2011 6:14 AM
Joined: Oct 14, 2011
Posts: 3
Hi please need help I have to pc's in my house with each their own copy of bfbc2 but when myself and my son wants to connect to the same server one of the pc's says "connection to game server lost" Both games are legal I bought them specially to play online together.
coolyouPM
#2
Oct 14, 2011 8:11 AM
Joined: Oct 12, 2008
Posts: 431
Maybe that server not allow to connect with same ip in the same time. Or maybe need to have different ips to play really don't know.
Former Gametracker Moderator.

- Please don't PM me since I'm retired, any PM's may go unanswered.
johanwepenerPM
#3
Oct 14, 2011 11:17 AM
Joined: Oct 14, 2011
Posts: 3
coolyou wrote:
Maybe that server not allow to connect with same ip in the same time. Or maybe need to have different ips to play really don't know.
But isn't there a way around that I'm not doing anything illegal.
coolyouPM
#4
Oct 14, 2011 12:09 PM
Joined: Oct 12, 2008
Posts: 431
johanwepener wrote:
coolyou wrote:
Maybe that server not allow to connect with same ip in the same time. Or maybe need to have different ips to play really don't know.
But isn't there a way around that I'm not doing anything illegal.

Do you use steam platform for bf2 ?
Former Gametracker Moderator.

- Please don't PM me since I'm retired, any PM's may go unanswered.
johanwepenerPM
#5
Oct 14, 2011 12:35 PM
Joined: Oct 14, 2011
Posts: 3
no I dont use steam.Both games are updated also.when we connect to different servers we can play.
rustedrootPM
#6
Oct 15, 2011 12:23 PM
Joined: Jan 02, 2011
Posts: 1
For those who are playing BC2 in the same network as another person:

Many are experiencing getting kicked when a friend on LAN joins the same server. To fix this:

Steam
- Go to Steam's My games menu
- Right-click on the BFBC2 and select Properties
- From the General tab, click the Set launch options button
- Add a different client port number on each machine between 27005 and 27032 in the following format:
- Code: +clientport 270XX (Where XX is a different number for each system - do not use 27020)

DVD
- Right click your shortcut for BFBC2; change your Target to something like "../../bfbc2.exe" +clientport 27011

For example. My shortcut to BFBC2 on my desktop has a targt line that reads like this:
"C:\Program Files (x86)\Electronic Arts\Battlefield Bad Company 2\BFBC2Game.exe" +clientport 27012

You may have to play around using different port numbers between the two machines. Remember, do not use 27020 and only use port numbers b/w 27005 and 27032

Source:
http://forum.ea.com/eaforum/posts/list/448777.page
grayham1990PM
#7
Mar 02, 2018 10:51 PM
Joined: Mar 02, 2018
Posts: 1
Hi,

I know this is an old thread, but I recently faced this problem and found a solution.

I am mainly posting here for anyone who might face it in the future, and myself in case I forget the solution.

The solution is NOT to use +clientport, this option is for Valve games.

The ports mentioned above are NOT the ports used by Bad Company 2, so using them will make no difference to your the executable's UDP port.

For Bad Company 2 to the solution is to add the following to your launch options:

-port 10001

If there are only 2 computers on your network trying to access Bad Company 2 then you only need to apply the above launch option to one. If there is more then two, then increase the port number, e.g. -port 10002 etc.

To make sure that UDP port was successfully changed open up task manager, click performance then "Open Resource Monitor". Under the Network tab you will find three sections, open up the "Listening Ports" (you may need to drag it up). Sort by name then search for BFBC2Game.exe and you will see a list of all the UDP ports, one of the ports listed should be that which you added to your launch options. If no launch option was added, the default port is 10000.

This solve the problem instantly for me.

Good luck