Vultr.com - Instant Cloud Server Deployment
GAMETRACKER FORUMS
Forum Home > General Help > GT reporting phantom player
irmandosPM
#1
GT reporting phantom player
Jan 11, 2017 4:02 PM
Joined: Jan 04, 2017
Posts: 3
Hello,

I have noticed that GT is reporting a player playing on our server without a name since I registered the server. It however does not match up with what ARK is reporting when I log in.

Can anyone maybe explain to me why GT is reporting this phantom player?


The screenshot was taken while I have the "showadminmanager" command open in ARK showing just myself as a connected player no other players. But with GT open in the overlay you can see GT is reporting that I am online and another player.

I read about bots not reporting correctly but I don't believe there to be any bots on ARK.
chimaera500PM
#2
Jan 11, 2017 5:19 PM
GAMETRACKER MODERATOR Joined: Jul 14, 2009
Posts: 1430
There is a query protocol: GT asks, the server responds.
GT can only report what the server tells it.

I am a community user. I am not able to provide support via PM.
You must use the forums please.
I will not reply to private message requests for support.

Forum Guidelines | Reporting abuse | Guides and FAQ
irmandosPM
#3
Jan 13, 2017 10:22 AM
Joined: Jan 04, 2017
Posts: 3
Chimaera500, thank you for your response. I listed this issue in a GT bug section as it clearly shows from the screenshot that my server only has 1 player on it. Can you maybe be so kind as to give me any details about the response GT gets so I can further investigate on my side?

I'm not trying to be dump but doesn't the whole Internet work on the principle of a device querying something and a server responding?
chimaera500PM
#4
Jan 13, 2017 10:45 AM
GAMETRACKER MODERATOR Joined: Jul 14, 2009
Posts: 1430
irmandos wrote:

...doesn't the whole Internet work on the principle of a device querying something and a server responding?

Precisely.
The game manufacturer informs what the query protocol/structure is.
The web developers write their code following that protocol.
The request is sent, the server responds.
There is little that web developers can do if the server reports incorrectly, except to display the data returned by the server.


irmandos wrote:
Chimaera500, thank you for your response. I listed this issue in a GT bug section as it clearly shows from the screenshot that my server only has 1 player on it. Can you maybe be so kind as to give me any details about the response GT gets so I can further investigate on my side?

I can't help personally, and do not have direct contact with the developers.
Burn reads all posts, and may be able to forward your request to the right people.

In the mean time, you could consider making a bug report to the server developers, or checking to see if such a report has been made to them before.


I am a community user. I am not able to provide support via PM.
You must use the forums please.
I will not reply to private message requests for support.

Forum Guidelines | Reporting abuse | Guides and FAQ
burnPM
#5
Jan 13, 2017 4:31 PM
GAMETRACKER ADMIN Joined: Sep 27, 2006
Posts: 10783
It's a bug with the game. It's been a problem since the game was released. You can safely ignore it on here. Hopefully the game developers eventually fix it.
@Vultr Cloud - Try it out with Free Credit

I am a community user.
Note: I neither read nor reply to PMs asking for support. Please use the forums for questions.

Reporting abuse | Guides & FAQ
irmandosPM
#6
Jan 14, 2017 12:45 PM
Joined: Jan 04, 2017
Posts: 3
burn wrote:
It's a bug with the game. It's been a problem since the game was released. You can safely ignore it on here. Hopefully the game developers eventually fix it.


Thank you for the feedback.
I will be ignoring it then.